CRM4.0 failure to detect asp.NET 2.0 being installed

An extremely usefull link about this problem: http://crm.vdsnickt.eu/2010/05/ms-crm-4-0-setup-error-asp-net-is-not-installed/

Ran into the problem while trying to upgrade from CRM3.0 to 2011 which requires 3.0 to be upgraded to 4.0.

The problem is caused by the CRM 4.0 installer being a bit retarded as the poster points out. Simply adding ASP.net 2.0 to the ASAPI filter list solves this issue.

Confirmed to work on 2003 R2 x64

This fix has also been confirmed to work on the 2008 R2 x64 SP1 installer but a noted feature here is to also still run %windir%\Microsoft.net\framework\v2.0.50727\aspnet_regiis.exe -i

Leave a Reply

Your email address will not be published.